Overview


Introduction

With the WooSignal WooCommerce SDK for Flutter, you can link a given WooCommerce store into your project using mobile SDK. We handles access to the WooCommerce REST API so you can just focus on integrating the WooCommerce store into your next project.

{info.fa-question-circle} Note: Our SDK is based on the WooCommerce REST API v3 so if you're familier with WooCommerce REST API you should find it similar.

You can retrive products, categories, orders and do many things that you'd expect from WooCommerce. Our platform also supports caching so you can get your results back even quicker ⚡️

When using the SDK you need to comply with WooSignal's Platform Terms of Service and ensure that your app complies with applicable laws. Note that when using the SDK, your application name and version, authentication information and a cross-application anonymous identifier is automatically sent with each request.

Requirements

  • WooCommerce 3.5+.
  • WordPress 4.4+
  • Website using HTTP or HTTPS protocol. HTTPS is recommended where possible.

Supported Platforms

WooSignal WooCommerce is only for Flutter app development at the moment. In the future to hope to support native iOS and Android.

Issues

We are working hard to ensure our documentation is clear and up-to-date.
If you discover any issues with our documentation, feel free to contact our support team via the following email support@woosignal.com